Website Outage

May 31, Thu
Affected Service: DYC Main Website (https://dudleyyouthcouncil.jimdo.com) Back-End Services
  • Investigating
    Our Host's Web Servers are currently experiencing issues.

    18:51, May 30 BST
  • Update
    We have contacted our hosts and hope to fix this problem.

    19:10, May 30 BST
  • Update
    Still no update on this issue. Apologies about the inconvenience.

    10:41, May 31 BST
Back to current status