Website Experiencing Connection Issues

November 01, Thu
Affected Service: Front-End Services
  • Identified
    Our Website is currently experiencing connection issues. Apologies about any inconvenience caused.

    10:32, Nov 01 BST
  • Monitoring
    This issue has been resolved and is being monitored, it was due to a large scale edit on our Back End.

    10:34, Nov 01 BST
  • Resolved
    Issue resolved. Apologies about any inconvenience caused.

    10:35, Nov 01 BST
Back to current status